Store Community Support Documentation
Announcements
Posts
.Posted in All commentsmust be moderated
Having an issue with comments on the siite. Running 4.8.1. Also had the problem before upgrading. Some coments get posted, and others get this message: "Your comment was successfully added, however this item requires that all comments be moderated by the owner before they are publicly displayed." The setting for comments must be approved before being displayed is set to "NO" This happens randomly and is getting frustrating. Anyone know how to stop this from happening?  It has even tolld me this when I've posted on my own comments. Other comments get posted right away. The post setting is "Everyone" so I can't seem to figure out what is going on. Thanks, Tim
Hello, My website was working fine. I could access as the admin but started getting reports of a 500 server error. To recreate it I had to log out, create a new account which it let me do, then after signup, it went to a 500 server error. This is only affecting resgistered users. I can log in as an admin and everything works fine. Registered users sign in and then get a 500 error. I had not changed anything on the site. It started happening on it's own. I tried upgrading to version 4.8.1 and am having thee same issue.  Can anyone help? Thanks! -- Tim  
I found this in my error log. Anyone know what it means? [16-Sep-2020 19:58:09 UTC] PHP Fatal error:  Uncaught Error: Class 'ComposerAutoloaderInit393d1ee8e8bb5b5d184d81451b095db1' not found in /home/tracyspointfl/public_html/PF.Base/vendor/autoload.php:7 Stack trace: #0 /home/tracyspointfl/public_html/PF.Src/Core/Engine.php(72): require() #1 /home/tracyspointfl/public_html/PF.Base/start.php(36): Core\Engine->initLoadClass('/home/tracyspoi...') #2 /home/tracyspointfl/public_html/index.php(5): require('/home/tracyspoi...') #3 {main}   thrown in /home/tracyspointfl/public_html/PF.Base/vendor/autoload.php on line 7  
Phpfox doesn't just 500 on it's own. Never heard of that in years using this. Check your server logs to see if you've been hacked. Solution: Simply restore from back up. GL  
The error I am finding is the one I isted above. Also the one below. I didn't do anything to cauwse4 this. The backup didn't work, nor did the upgraded fix it.  [16-Sep-2020 20:00:02 UTC] PHP Warning:  require(/home/tracyspointfl/public_html/PF.Base/vendor/composer/../myclabs/deep-copy/src/DeepCopy/deep_copy.php): failed to open stream: No such file or directory in /home/tracyspointfl/public_html/PF.Base/vendor/composer/autoload_real.php on line 66  
OK, I uploaded a fresh batch of files from the zip folder I downloaded from the client area and that fixed the problem. All the errors I could find pointed to an auto loaded problem but that is beyond my abilities. I'm not sure what caused it but it wasn't anything I did. Hadn't changed anything since it previously working fine. No 3rd party apps or anything so I don't know. Anywa, that goo it fixed. Thanks! Tim
.Posted in Amazon s3 not working with 4.81
Hi Alexander Frez Prado, Please kindly go to AdminCP > Settings. > Storage system to configure for your storage. We would like to confirm that phpFox moved this setting to the core features (adminCP) from phpFox v.4.8.0.  For more information, please refer https://www.phpfox.com/blog/2020/phpfox-4-8-0-official-release/ Regards,
.Posted in 4.8.1 upgrade stalls
https://i.gyazo.com/c57fedfb053c6316b4c4a1e8d34c1a30.mp4   as you can see in this clip, when i go to install its stalls out and never changes,  file permissions are correct, restarting it does not resolve the issue and my site is stuck in upgrade mode. 
.Posted in 4.8.1 upgrade stalls
update, i have tried the 3 solutions on the how to    While upgrading to version 4.5.3 or later, you may face errors and most of those cases are caused by lack of write permissions on "PF.Site/Apps" folder when upgrading phpFox site with "File System" FTP option. In this case, we have some quick solutions for you: - Solution 1: Update permission 777 to "PF.Site/Apps" folders and its subfolders/files recursively. Then you can follow our guidance to upgrade again and can use "File System" option - Solution 2: Skip step to upgrading apps with phpFox by unchecking all apps. You can still use "File System" option. - Solution 3: If you still want to upgrade apps while upgrading phpFox, please use "FTP/SFTP" option which FTP account has write permission on "PF.Site/Apps" folder If you have faced any other issues or other solutions while upgrading phpFox, feel free to share us here.   None of these worked for mew unfortunatley
.Posted in 4.8.1 upgrade stalls
Why does it take so long to update a website with the phpfox new files?  It takes over 6 hours to updates files by FTP.  That is just ridiculious.  I wish that PHPFox would have only the necessary changed files needed to upload and update instead of all of the files.  This is becoming really BAD for update your website and having it to be down for over 6 hours just for some update.
I think its an .htaccess bad config file.  If you dont have .htaccess file in your root directory, please create one, with the following code: <IfModule mod_rewrite.c>   RewriteEngine On   RewriteBase /       RewriteRule ^static/ajax.php index.php   RewriteRule ^themes/default/(.*) PF.Base/theme/default/$1   RewriteRule ^(file|static|theme|module)/(.*) PF.Base/$1/$2   RewriteRule ^(apps|themes)/(.*) PF.Site/$1/$2       RewriteCond %{REQUEST_FILENAME} !-f   RewriteCond %{REQUEST_FILENAME} !-d   RewriteRule ^(.*) index.php/$1   </IfModule   Save it, then look in your server for "sec_mod" and disable it just to install the script.   
.Posted in 4.8.1 upgrade stalls
Hi Vanucci, We would like to confirm that there are many cases related to this issue so kindly open a new support ticket from your client area with your server information so that our technical team can investigate and give you a solution for this issue. Best regards,
julio
.Posted in Map
Hi,  I had maps working fine in my site.  Now maps are displaying a general map ( i guess).  I have an active API key, my billing info is up to date at Google console. im using phpfox V4.8 Any ideas on what should i check?
julio
.Posted in Map
I have got the message attached as well