Install - Upgrade

After posting my comment above, I ran the same checks on my site and came up with 107 failed files. I overwrote the entire install with the most recent version, rebuilt the theme, ran the "find missing settings" option, and cleared the cache. When I checked again, I still had 107 failed files. 2 of which are missing apparently. This leads me to believe this is a bug with the modified files checker. So I would probably wait until the next version to overwrite anything else. No sense in doing extra work that we can't actually double-check at this point right?

For your specific issue however, make sure that the following file is present. If not, update/overwrite it as it appears to control the part you are having a problem with:
PF.Site/flavors/material/html/user.block.tooltip.html.php

 

April 29, 2018 7:34 am

Fixed it!   When I uploaded my files I used Fil;ezilla and I did the drag and drop.  for some reason, no files were transfered even though it appeared as if the files were transfering.  I had to look at my files to see when the last modified date was.  

 

I went back to filezilla and right clicked on the files to be uploaded and clicked upload and it actually uploaded this time.  

Site is now updated.  I had to go through the install steps to update it.

 

May 28, 2018 5:03 am

I am having issues with the privacy module how do I enable or disable it? I am getting is this error in the event module.



2018-09-24 10:22:45
[256] Calling a Service from an invalid Module. Make sure the module is valid or set to active. (privacy::privacy) (/home/runcloud/webapps/mysite/PF.Base/include/library/phpfox/error/error.class.php) [99]
Error Code: e4f44e
Stack trace:
#0 /home/runcloud/webapps/mysite/PF.Base/include/library/phpfox/error/error.class.php(99): trigger_error('Calling a Service from an invali...', 256)
#1 /home/runcloud/webapps/mysite/PF.Base/include/library/phpfox/module/module.class.php(989): Phpfox_Error::trigger('Calling a Service from an invali...', 256)
#2 /home/runcloud/webapps/mysite/PF.Base/include/library/phpfox/phpfox/phpfox.class.php(745): Phpfox_Module->getService('privacy', Array)
#3 /home/runcloud/webapps/mysite/PF.Base/include/library/phpfox/search/browse.class.php(182): Phpfox::getService('privacy')
#4 /home/runcloud/webapps/mysite/PF.Site/Apps/core-events/Controller/IndexController.php(236): Phpfox_Search_Browse->execute()
#5 /home/runcloud/webapps/mysite/PF.Base/include/library/phpfox/module/module.class.php(1170): AppsCore_EventsControllerIndexController->process()
#6 /home/runcloud/webapps/mysite/PF.Base/include/library/phpfox/module/module.class.php(580): Phpfox_Module->getComponent('AppsCore_EventsControllerInde...', Array, 'controller')
#7 /home/runcloud/webapps/mysite/PF.Base/include/library/phpfox/phpfox/phpfox.class.php(1614): Phpfox_Module->getController()
#8 /home/runcloud/webapps/mysite/PF.Base/start.php(636): Phpfox::run()
#9 /home/runcloud/webapps/mysite/index.php(9): require('/home/runcloud/webapps/mysite...')

Hi jimimysilva,

Please submit us a support ticket and we will check on your site. 

September 26, 2018 2:21 am

Hi, I found a bug in latest release Phpfox 4.6.1b6. When I click edit on the submenu "About Me" in admincp Members ->Custom Fields I get a 500 error page. Phpfox 4.6.1b5 does not have this issue. It happens after upgrading to 4.6.1b6 and on new installation of Phpfox 4.6.1b6.

Here is the error log. Advise? Thanks.

 

Error Code: 6bbdea
Error: Class 'CoreLib' not found in /home/domain/public_html/PF.Base/file/cache/template/custom_template_default_controller_admincp_add.html.php_admincp.php:625
Stack trace:
#0 /home/domain/public_html/PF.Base/include/library/phpfox/template/template.class.php(3578): require()
#1 /home/domain/public_html/PF.Base/include/library/phpfox/template/template.class.php(3564): Phpfox_Template->_requireFile('/home/domain/p...')
#2 /home/domain/public_html/PF.Base/include/library/phpfox/template/template.class.php(2899): Phpfox_Template->_getFromCache('/home/domain/p...', 'custom.controll...')
#3 /home/domain/public_html/PF.Base/include/library/phpfox/module/module.class.php(633): Phpfox_Template->getTemplate('custom.controll...')
#4 /home/domain/public_html/PF.Base/file/cache/template/adminpanel_default_template_template.html.php_admincp.php(206): Phpfox_Module->getControllerTemplate()
#5 /home/domain/public_html/PF.Base/include/library/phpfox/template/template.class.php(3578): require('/home/domain/p...')
#6 /home/domain/public_html/PF.Base/include/library/phpfox/template/template.class.php(3564): Phpfox_Template->_requireFile('/home/domain/p...')
#7 /home/domain/public_html/PF.Base/include/library/phpfox/template/template.class.php(2626): Phpfox_Template->_getFromCache('/home/domain/p...')
#8 /home/domain/public_html/PF.Base/include/library/phpfox/phpfox/phpfox.class.php(1781): Phpfox_Template->getLayout('template')
#9 /home/domain/public_html/PF.Base/start.php(636): Phpfox::run()
#10 /home/domain/public_html/index.php(9): require('/home/domain/p...')
#11 {main}

Hi pcemail,

Thanks for your report. I confirm that this is a bug in version 4.6.1b6 and we'll fix in next version. Sorry for this inconvenience.

September 26, 2018 2:57 am

Hi Jemery,

I can confirm that this header param (X_PF_CACHE_FAILED) is no longer used and has been removed in recent phpFox versions. You can consider upgrading your phpFox site to the latest version. Anyway, you can ignore it since there are no impacts.

Have a nice day.

Paul

September 26, 2018 3:27 am
DanShea
Posted By
3
unsecure.JPG

Yes, it's fixed now and it was a block I had on each page that had http links instead of https links. 

 

November 12, 2018 2:53 am

Hello

now , and after  many days and hours of headche,  I upgraded to 4.6.b1 .

I see the site . I  see the theards title  I see the topic  titles >> but >>  I cannot  see  the  sentences in topics! .:open_mouth:  

previous  version had not any  error , all occured  after upgrading form 4.2.2 to 4.6  version. 

please help where  i must to  correct?

 

November 30, 2018 5:43 pm

I have experienced something new since phpfox 4.7 fresh install.

 

After I install I got a meesage that I not install correctly but when I refresh the site. The site is working good without any issues.

December 6, 2018 8:08 pm