But no seriously, is mod rewrite included in the alpha, I installed it on my server, but I didn't see that option so all my URLs are like index.php?do=...
Be the first person to like this.
Quote:
Originally posted by: webmasterx
But no seriously, is mod rewrite included in the alpha, I installed it on my server, but I didn't see that option so all my URLs are like index.php?do=...


Good question... I have not realized until you mention that Tongue
Be the first person to like this.
LOL I just have an obsession with clean looking URL, even after mod rewrite in 1.6, I had to alter the phpfox URL class to tweak the urls till they were PERFECT.
Be the first person to like this.
Raymond Benc
Added a new entry in the wiki on how to enable mod_rewrite:
http://wiki.phpfox.com/guide/V2/Post_Install#Installing_Short_URLs_with_mod_rewrite

Let me know if you run into any problems.
Be the first person to like this.
Tested&Working perfectly
Be the first person to like this.
Added it to the bug tracker so the installer is smarter wink Think we'll see it on the final release
Be the first person to like this.
Quote:
Originally posted by: natio :: phpFox
Added a new entry in the wiki on how to enable mod_rewrite:
http://wiki.phpfox.com/guide/V2/Post_Install#Installing_Short_URLs_with_mod_rewrite

Let me know if you run into any problems.


I have found a problem, but I think it is related to the way I have configured my localhost server.

Server config:
Intel Core 2 Duo 2.0Ghz
2GB RAM DDR2 667Mhz
Kubuntu 8.10 Intrepid i386
Kernel 2.6.27-9 + Apache 2.2.9 + MySQL 5.0.67 + PHP 5.2.6

When I have renamed the file htaccess.txt to .htaccess, a 500 Internal Server error appeared.

I have commented the following lines in the .htaccess file, and everything worked fine:

# Cache files
<FilesMatch ".(ico|pdf|flv|jpg|jpeg|png|gif|swf|mp3|mp4)$">
Header set Cache-Control "public"
Header set Expires "Thu, 15 Apr 2010 20:00:00 GMT"
Header unset Last-Modified
</FilesMatch>
 
# Cache JavaScript & CSS
<FilesMatch ".(js|css)$">
Header set Cache-Control "public"
Header set Expires "Thu, 15 Apr 2010 20:00:00 GMT"
Header unset Last-Modified
</FilesMatch>


Perhaps any of you know what is happening, or what I'm lacking in my server.

Thanks!
Be the first person to like this.
Raymond Benc
Quote:
Originally posted by: Fern :: phpFox
I have found a problem, but I think it is related to the way I have configured my localhost server.

Server config:
Intel Core 2 Duo 2.0Ghz
2GB RAM DDR2 667Mhz
Kubuntu 8.10 Intrepid i386
Kernel 2.6.27-9 + Apache 2.2.9 + MySQL 5.0.67 + PHP 5.2.6

When I have renamed the file htaccess.txt to .htaccess, a 500 Internal Server error appeared.

I have commented the following lines in the .htaccess file, and everything worked fine:

# Cache files
<FilesMatch ".(ico|pdf|flv|jpg|jpeg|png|gif|swf|mp3|mp4)$">
Header set Cache-Control "public"
Header set Expires "Thu, 15 Apr 2010 20:00:00 GMT"
Header unset Last-Modified
</FilesMatch>
 
# Cache JavaScript & CSS
<FilesMatch ".(js|css)$">
Header set Cache-Control "public"
Header set Expires "Thu, 15 Apr 2010 20:00:00 GMT"
Header unset Last-Modified
</FilesMatch>
Perhaps any of you know what is happening, or what I'm lacking in my server.

Thanks!


Good to know. If you try to add this in the .htaccess file:
Header set Cache-Control "public"


Do you get an internal server error with just that?
Be the first person to like this.
Quote:
Originally posted by: natio :: phpFox
Good to know. If you try to add this in the .htaccess file:
Header set Cache-Control "public"


Do you get an internal server error with just that?


I have this error too.
Adding Header set Cache-Control "public" to .htaccess doesn't help

Here is the apache err log:

[Fri Jan 16 13:59:33 2009] [alert] [client **.**.**.**] /usr/local/apache2/htdocs/alpha/.htaccess: Invalid command 'Header',
perhaps misspelled or defined by a module not included in the server configuration, referer: ......


PROBLEM SOLVED!!!!
Seems that phpfox2 needs a Apache with a module headers enabled. If this module is not enabled the phpfox2 will not work with .htaccess, short urls and etc.

Enabling module headers may be done in this way (Debian with Apache 2):


server:/# a2enmod headers
Enabling module headers.
Run '/etc/init.d/apache2 restart' to activate new configuration!
server:/# /etc/init.d/apache2 restart
Restarting web server: apache2.
Be the first person to like this.
Raymond Benc
Quote:
Originally posted by: sharo
I have this error too.
Adding Header set Cache-Control "public" to .htaccess doesn't help

Here is the apache err log:

[Fri Jan 16 13:59:33 2009] [alert] [client **.**.**.**] /usr/local/apache2/htdocs/alpha/.htaccess: Invalid command 'Header',
perhaps misspelled or defined by a module not included in the server configuration, referer: ......


It is what is causing the problem. So you will need to remove the following:

# Cache files
<FilesMatch ".(ico|pdf|flv|jpg|jpeg|png|gif|swf|mp3|mp4)$">
Header set Cache-Control "public"
Header set Expires "Thu, 15 Apr 2010 20:00:00 GMT"
Header unset Last-Modified
</FilesMatch>
 
# Cache JavaScript & CSS
<FilesMatch ".(js|css)$">
Header set Cache-Control "public"
Header set Expires "Thu, 15 Apr 2010 20:00:00 GMT"
Header unset Last-Modified
</FilesMatch>


Once the Header code is removed it should work. Let me know how it goes.

Thanks
Be the first person to like this.
Quote:
Originally posted by: natio :: phpFox
Good to know. If you try to add this in the .htaccess file:
Header set Cache-Control "public"


Do you get an internal server error with just that?



Yes, 500 Internal server error.


Quote:
Originally posted by: sharo

PROBLEM SOLVED!!!!
Seems that phpfox2 needs a Apache with a module headers enabled. If this module is not enabled the phpfox2 will not work with .htaccess, short urls and etc.

Enabling module headers may be done in this way (Debian with Apache 2):


server:/# a2enmod headers
Enabling module headers.
Run '/etc/init.d/apache2 restart' to activate new configuration!
server:/# /etc/init.d/apache2 restart
Restarting web server: apache2.



Worked perfectly!!! Thank you sharo!
Be the first person to like this.