Store Community Support Documentation
Let's say I simply want to ban every IP from 210.0.0.0 to 210.255.255.255, under the assumption that anything in that range (among many others) will be from China. In Tools -> Ban Filters -> IP Address, is there a preferred format for using the * wildcard?

In other words, would I use 210.*.*.*

or

210.*

or

210* (no dot)

or something else? Thanks.
Be the first person to like this.
Sorry can't really be of any help here except to say that I am 99% sure this was covered in a previous post. Try a quick search for it
Be the first person to like this.
#2
Quote:
Originally posted by: ringspun
Sorry can't really be of any help here except to say that I am 99% sure this was covered in a previous post. Try a quick search for it


I did that already. One previous post concerned using the * wildcard to ban email names (such as *.cn) which is a different issue. None of the other threads searched addresses this particular question. Still hoping for an answer from someone...
Be the first person to like this.
#3
no preferred way, it gets converted to a regular expression where the asterisk means "anything", so:
200.*
would be
200.[anything]

which has the same effect as
200.*.*.*
Be the first person to like this.
#4
If your using 2.0.5 don't hold your breath - the wild cards don't work. In 2.0.4 anything of the afore mentioned schemes would work. Fix please.
Be the first person to like this.
#5
I have the same problem and would LOVE for the * to work. It just doesn't. Any chance it will be fixed? Many days I have 3-9 bogus users setting up accounts. It is a pain to enter individual IPs when there is a range. Thanks much.
Be the first person to like this.
#6

How can we banned email using *@mail.ru or *.ru

we're running phpfox 4.5.3, now we enter *.ru or *@mail.ru it said invalid email

but 122* it works, please advice what is the wildcard to use to ban all new sign up example with email *.ru

please advice?

Be the first person to like this.
Jonathan Mitchell
#7

I would just do it through your cpanel, under Security- IP Blocker

#8

but the cp->ban filter mention we can ban email by using * for wildcard, it only work for ip 146* but it doesn't work for email *.ru or *ru it keep saying invalid email, please advice how to block email using wildcard? or any fixes or update to the code? i'm running 4.5.3 

Be the first person to like this.
Jonathan Mitchell
#9

I get the same thing on 4.6.0 ... Hopefully they fix it soon..until then, i usually just use the cpanel

Be the first person to like this.
Robert
#10

I get the same thing on 4.6.0 ... Hopefully they fix it soon..until then, i usually just use the cpanel

Hi Jonathan Mitchell,

We can confirm with you that the issue "The ban filter with wildcard email doesn't work" will be fixed in the next patch of phpFox 4.6.1.

Thanks for your report and sorry about this inconvenience.

Be the first person to like this.
Robert
#11

Hi all,

We have fixed this issue on phpFox core 4.6.1. Please help us to check it again.

Be the first person to like this.