Donna(data66)
We seem to have some confusion among some members that are not familiar with what a BETA and RC version of the script is.

BETA is a first release for TESTING ONLY. It is not for a live site. It will not have any third party templates that work with it. Third party add ons also might not work on it. It is for helping us to test the script by as many people as we can get testing it.

RC is a Release Candidate and usually still has some bugs and so if you use it on a live site, it can still have problems. RC versions still won't have templates by third party developers in most cases. It's best to wait for Stable version to upgrade a live site after ensuring your add ons and template are compatible.

**DO NOT try to test BETA or RC with any third party add ons or templates.
**DO NOT have a BETA as a live site. If you do that, you risk having your members and info lost if there are glitches with the BETA. You would be using the BETA at your own risk.
**NO support is given for BETA versions. We do have the bug tracker for bugs but not for site issues if you install this and have issues in your site that are not bugs in the script.
**DO NOT modify the source on a BETA or RC. (modifying source is also not recommended on the stable releases)

These are just some of the points regarding BETA and RC versions.

Please do not post angry posts if you don't see this feature or that feature on your custom 3rd party template with the BETA or RC. NO template designer will make a template for BETA or RC. They wait for stable releases due to last minute template coding changes that are sometimes made.

If you did not read the above and find that you have errors on your site with 3rd party add ons, DO NOT contact that developer asking for support of the BETA or RC. They are only going to support the Stable versions.

If you loaded the BETA to live, and did not read in the blog where it said not to do that, you will need to load your back up of your files and database.

Hope this helps.
Last update on October 6, 2012 by Donna(data66).
This thread is closed
Donna(data66)
I already suggested this yesterday and hope it is implemented in future blogs. I did post a notice in the blog comments about this too.
Be the first person to like this.
Hi i upgraded a fresh install to RC because of the HTML5. Unfortunately my TM Tabslider is no longer working. Does anyone have any idea why the TM Tabslider doesn't work in the RC version or if there is a simple fix for it please?
Be the first person to like this.
Donna(data66)
Please re-read this. Add ons are not updated by developers until stable is released
Be the first person to like this.
Oh i can read, in fact i have read but only after i found there was an issue.

Considering if you go to the rc download page it quite clearly says "This is a Release Candidate version and is officially supported by our team. If you have recently started a new community or plan on starting a new community we strongly advice to use v3.6.0 RC1."

It doesn't say "you will have problems with addons"

so thanks for your advice but 'shutting the stable door after the horse has bolted' springs to mind!
Last update on June 27, 2013 by urbanfmtv.
Be the first person to like this.
The "warnings" have been all over the forum for a long time, posted by many people. There are stickied threads as well, all stating the same thing. It has always been advised to only use Stable Releases in a Live environment. Not just for phpFox but for most software out there.

As a matter of fact, this is the first time I believe I have seen in the blog that if you are running a new community, it is advised to use the RC, I understand the reasoning...it is due to the security, maintenance and optimization settings.

RC = release candidate...it doesn't say Stable Release.

as for addons, before upgrading you should ALWAYS check with addon developers to make sure that they have upgraded, even AFTER stable is out....
Last update on June 27, 2013 by mostlymom.
Be the first person to like this.
Don't you think someone should just add that to the blog?

and that's not quite true as your first post on this page says exactly that lol

"Posted June 26, 8:42 pm 2013
Per the blog for 3.6 RC1

"This is a Release Candidate version and is officially supported by our team. If you have recently started a new community or plan on starting a new community we strongly advice to use v3.6.0 RC1."
"
Last update on June 27, 2013 by urbanfmtv.
Be the first person to like this.
Yes my first post states that...BUT I do state in the post you are replying to that I don't believe I have ever seen that posted before, and that I understand why it was stated THIS time.

It was my error that I did not add in my other post that you should always check with addon developers to make sure they are ready for the latest release as well...but I guess that I thought that common sense would tell you that phpFox doesn't update the addons, and that updated phpFox might mean you would want to make sure addons were updated too....
Be the first person to like this.
Donna(data66)
Another bump to get people reading it.
Be the first person to like this.
bump
Be the first person to like this.
Donna(data66)
Another bump. Please do not upgrade your live established PHPFox sites with the RC especially if you have any add ons or any custom templates.
Be the first person to like this.
Donna(data66)
Bump! Please read!
Be the first person to like this.
Donna(data66)
Another bump
Be the first person to like this.
Donna(data66)
In preparation for our Beta release of v4.4 next week, I'm moving this old post to the Neutron v4 area so you all are aware not to upgrade a live with with the beta release.
spirog
hi I am testing latest beta version 4.4.0 and on loading the main page example www.myphpfoxdomain.com it was a little slow loading and I inspected via Firefox and found the 2 files below.
I would like to know how many more files are not part of the script ?
meaning pulled from somewhere else, i saw this just now and was wondering why its pulling from somewhere else and not part of an image on our server ?
just cause it took a little bit to load this image create-a-social-network-for-fine-cooking.jpg file..
not sure about the .js file if that was a delay also.
these are the 2 i saw not even really looking but noticed it.
https://cdnjs.cloudflare.com/ajax/libs/moment.js/2.10.6/moment.min.js
and
http://bg.m9.io/create-a-social-network-for-fine-cooking.jpg
is there a way to change this to be on our own web server so it pulls from our own server ? if so what files do i change and what other images would i download to add them to my server for fast loading..
Is there a special reason it is not loading on our server ?
I just feel if it was on our server we would not have to worry if an interruption occurs on http://bg.m9.io/ and then we will be able to see the image and it will slow down the load time :)
thanks in advance for your reply
Spiro
Thanks Spiro
4.4.0 beta
Be the first person to like this.
Donna(data66)
This thread is not for asking questions about the release. Please post a new thread for that.
Be the first person to like this.