Store Community Support Documentation
We seem to have an issue with clients upgrading their sites without first waiting for their template designers or their 3rd party add on developers to post if the templates and add ons are updated to work.

We have posted before warnings not to do this and are now posting another thread that will be stickied.

Custom Templates (not phpFox default)

Template designers wait until stable version is released before making their upgrades for them. This is due to last minute template changes that can come in the stable version and is a best practice method of doing updates in order to not miss any last minute changes.

Each designer has their own method to notify their clients when the updates are done. Please be patient and wait. If you think sending a thousand emails to them to hurry and get your purchased template upgraded will help, you are mistaken. It only slows the process as they answer your emails as well as those of their thousands of other clients. Please wait for their announcements.

If you have a custom made template, you will need to check with your designer to see when they will be able to update your custom designed template and if there is a fee. Some charge and some don't. That's up to them but please be patient and allow them some time to update your template for current versions.

Third Party Add ons

Each add on has it's own features and some will work with new releases without any issues but others will make your site blank, have errors or just not work right if you upgrade without waiting for the product to be updated. Please wait for the third party developer to post that their products work with current versions or that their products are updated to work.

Just as with the template designers, please don't post a bunch of emails to support of these add ons asking when they will be working for new versions as this will slow the updating process while the developers stop to answer questions from all of their clients.


What if you upgrade first without waiting


If you decide to upgrade without checking with your 3rd party developers and then your site does not work, please don't post angry messages to these developers expecting them to drop everything to fix your site. They are trying to get their products updated and your mistake does not need to be their problem.

Our support will also not fix your third party add ons or templates.

The best thing to do is patiently wait before upgrading to ensure your add ons and templates will work with your site. Make a development clone of your site also, so you can test the upgrade on that before upgrading live site, even with the updated templates and add ons.

If you choose to update your live site and then it's down or messed up, the third party developers are under no obligation to provide you support for this issue. Please be aware of that.
Last update on March 17, 10:54 am by Donna(data66).
Donna(data66)
#1
Guess I have to bump this again. Do not upgrade your site until you check with your 3rd party developers as most wait for stable release to start updating their add ons or templates. If you upgrade, you will probably need to disable your templates and add ons until they are upgraded.
#2
Quote:
Originally posted by: Spiritual Networks

Totally agree but we have been unable to reach Teamwurkz for over a month.

TemplateMechanic usually gets the updates for all of his templates done within a week or two after the stable release of PF.
Be the first person to like this.
metro
#3
She is too "bumpy" for me Smile

Quote:
Originally posted by: Spiritual Networks

I would just like to thank data66 for her kindness and patience. She goes above and beyond for the phpfox community. Most organizations wait a lifetime for support like this and we are forever grateful.
Be the first person to like this.
#4
So I guess this will be a pain for those with their own custom templates? oh gosh, said it before and i'll say it again, something has to be done about upgrades,

we don't all want 3rd party templates or default, some like to actually have a unique site, I mean we can't all have same site or niche

Upgrades should be something to look forward to not something we dread, worst of all is we need to to get rid of bugs even though usually for every bug fixed a new one pops up

I just really hope the upgrade system you suggested gets accepted, upgrading you see the problems they create, they are real and they are many
Last update on July 14, 9:47 am by Sith.
Be the first person to like this.
Donna(data66)
#5
It needs votes to be accepted. Smile
Be the first person to like this.
Be the first person to like this.
#7
On V2 I stopped upgrading at 2.5 because I saw this happening frequently whenever I tested the newer versions and when I finally upgraded my site to V3 it was great in the beginning of this cycle but pretty much the same pattern.

I'm not upgrading beyond V3.5 as I've tested 3.6 and there are too many things that have stopped working and lots of newer bugs. Yes they fix them but other things stop working.

I'm glad I am not the only feeling the same about these upgrades and how things that worked stop working on upgrades. And I don't buy into the "all software has bugs" used to soften the problems. Yes all software has bugs but I see more bugs with this software than I do other scripts I have tested and am now using.

I voted Yes on data's feature request that is one of the best plans she has put together and I think the Fox owners should seriously consider implementing one of those options at http://www.phpfox.com/tracker/view/13727/



Quote:
Originally posted by: Sith

So I guess this will be a pain for those with their own custom templates? oh gosh, said it before and i'll say it again, something has to be done about upgrades, we don't all want 3rd party templates or default, some like to actually have a unique site, I mean we can't all have same site or niche

Upgrades should be something to look forward to not something we dread, worst of all is we need to to get rid of bugs even though usually for every bug fixed a new one pops up

I just really hope the upgrade system you suggested gets accepted, upgrading you see the problems they create, they are real and they are many
Be the first person to like this.
#8
Thank you Jesus!! I just seen this thread and went and voted yes immediately. We can only hope that 1) it's possible for the PF crew to be able to update the script in any of the ways data mentioned and 2) that this this gets a lot of votes this is more important than any other request right now that security and speed have been fixed! so please vote this up @ http://www.phpfox.com/tracker/view/13727/
Last update on July 14, 2:54 pm by kraze2007.
Be the first person to like this.
#9
Spread the word to ALL your friends and ask them to vote YES on data's request at http://www.phpfox.com/tracker/view/13727/
Be the first person to like this.
#10
I don't have a bunch of fancy templates ... I DO have a BUNCH of super neato add-ons however. So far, I've been really, really lucky that these add-ons haven't been problematic.

A few add-ons I'm still playing with and figuring out how best to use on my dev clone, but I HAVE NOTICED, that almost all of the add-ons I have, claim to be the "current version" in the AdminCP?

admincp/product/ (AdminCP -> Extensions -> Manage Products)
this page says all my add-ons are the current version. Most have NOT been updated since 3.3.0 was released.

Most of the add-ons I'm using are paid and from the more well known developers. Konsort.org, RAEL, PHPfox.pro, brodev, phpFoxguru and one freebee from SocialLoft (Scroll to Top is THE BOMB)

This DOES concern me a bit, but so long as the add-ons work ... I'm not gonna be that fussy 'bout it. I do realize I'm skating on very, very, very thin ice and risking falling in. I always did kinda like playin' with fire ... :/
That's why I let new releases go thru the ringer on the dev clone for a week or so, BEFORE I throw it on the live site.
Last update on July 14, 6:22 pm by t3ln3t.
Be the first person to like this.
#11
It would appear 3.6 has affected the vast majority of mods, so my advice is really to hold off upgrading at this point.

3.6 was all about improving the core and that's why it's such an issue this time round.
Last update on July 17, 10:55 am by Dazzy.
Be the first person to like this.
Donna(data66)
#12
And just to be sure, bumping this as we released RC today but please do not upgrade a live, established site to an rc version especially if you have add ons.
Be the first person to like this.
Donna(data66)
#13
Bumping so people remember to first check with 3rd party devs before upgrading
Be the first person to like this.