I need to find some info or help on how to fix some 404 errors I been getting.

When I first started with phpfox I had phpfox as my main site and wordpress as a subfolder. About a year back I changed it an moved my wordpress site to my main site an phpfox to a subfolder.

before: phpfox/wordpress
after: wordpress/phpfox

The problem am having is that I have a lot of 404 errors now because most all the phpfox urls have changed. I was wondering if anyone know or can pin point me on how to fix this issue a redirect it properly via htaccess.
Be the first person to like this.
my rewriteBase is like this

rewriteBase /community

my phpfox site is also in community

the only difference I see is this one

mine:
RewriteRule (.*) http://www.websitename.com/community/$1 [R=301,L]

yours:

#RewriteRule ^(.*)$ http://www.% {HTTP_HOST}/$1 [R=301,L]

the only thing I see is the yours has a # which comments out the request.

the links that are giving me errors look like this.

http://www.websitename.com/username/video/name-of-video

the way it should look now is

http://www.websitename.com/community/video/32110/name-of-video

I am also running 3.6 build 6
Be the first person to like this.
Donna(data66)
Are you sure you replaced the old .htaccess with the latest one as we have made changes along the way and it is good practice to replace old ones with new ones when you upgrade
Be the first person to like this.
am replacing t he .htaccess right now
Be the first person to like this.
after updating do I need to reset anything?
Be the first person to like this.
Kirk
Only if you're using short URLs... http://www.phpfox.com/kb/article/63/short-urls-rewrite-rules/
Be the first person to like this.
Updated the .htaccess with the new one an its still giving me 404 errors I know I have to ad some thing just don't know what.

Old url: 404
www.website.com/username/video/name-of-video/

if I visit the url an add /community/ after the website.com it doesn't display a 404 error any more and changes the url to:

www.website.com/community/video/4455/name-of-video/
Be the first person to like this.
Donna(data66)
your .htaccess is:

RewriteBase /community/

your server.sett.php file has:

$_CONF['core.folder'] = '/community/';
Be the first person to like this.
also make sure to clear the site cache.
Be the first person to like this.
My server.set.php file is like this

$_CONF['core.host'] = 'www.website.com';;
$_CONF['core.folder'] = '/community/';
$_CONF['core.url_rewrite'] = '1';

My htaccess file is like this

RewriteBase /community/

Cleared site cache still have same problem.
Be the first person to like this.
Donna(data66)
Please submit a ticket to support.
Be the first person to like this.
Kirk
Yeah, there's something funky going on, then.
Be the first person to like this.
I did submit a ticket but got no help Unhappy my ticket number was #FAS-338-11032 Am at lost to how to fix this major issue the biggest problem I have is that my site receives a lot of traffic and the 404 error causing a mess.

Data66 Maybe you can help me by asking purefan or someone to check this post to help me out.
Be the first person to like this.
Donna(data66)
Please note that weekends we are short staffed. I am sure a technician will assist you.
Be the first person to like this.
I actually submitted the ticket on Monday, but hopefully I can get a reponse. Thanks data
Be the first person to like this.
Hello,

I checked the status of your ticket and it's 'Waiting reply' which means that we are waiting your reply to the ticket. You opened it on July 19th and an agent answered it on the same date.

Please reply this ticket explaining some more your issue, for us to help you. Also, adding the link to this thread could help.
Be the first person to like this.