Dude
** Update **
when I type mysite.com or www.mysite.com my site don't switch to secure https and I can't loging unless I manually type https://www.mysite.com
I went to >> Security and turn Force HTTPS for Logged In Users to true.
Any ideas
Last update on January 4, 2014 by Dude.
Hello,

This is a server configuration, I have setup a SSL following this tutorial:
* http://extrimity.in/content/enable-ssl-or-https-ubuntu-1104-apache-2

And all the conections are using https.

However, other simple sulution could be to add a redirect in the htaccess as follow:

After the line #19 to add

RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
Dude
In my case I Did not enable "Secure Pages with HTTPS" because is not on the security page.
Manage Settings » Security: Force HTTPS for Logged In Users

Manage Settings » Server Settings: Secure Pages with HTTPS
That solved my problem.

Thanks for the reply.
Fred Beall
That last post by Dude really helped me.
Fred Beall
Quote:
Originally posted by: Dude

In my case I Did not enable "Secure Pages with HTTPS" because is not on the security page.
Manage Settings » Security: Force HTTPS for Logged In Users

Manage Settings » Server Settings: Secure Pages with HTTPS
That solved my problem.

Thanks for the reply.


I need help!

I turned on both the above (set to true), and it worked great to secure the site. It caused every page to be forced to SSL. Great.

However, it completely broke our iOS app logins and our Android app logins (apps made by phpfox.pro).

Here is my problem: I tried to switch them off, and I did not know they have to be switched off in a certain order! Now I cannot edit any settings in my own control panel!

I am pretty sure I set to false this one:
https://www.azusastreetriders.com/asr-dashboard/setting/edit/group-id_security/

That seems to have resulted in me being "logged out" immediately. I now cannot login unless I manually add HTTPS to the URL. Even then, I cannot get to the control panel without manually adding HTTPS, and if I do manually add it, when I make a change and click submit, I get shown a profile page as though I am not logged into the control panel. The update does not "take."

When I went to set the other option to false, my updates were ignored. When I went to set the first one to true, my updates were ignored.

Can someone guide me on where to look in the database to edit this setting? What table?
Last update on April 27, 2014 by Fred Beall.
Fred Beall
Update:

I was googling for tips, and found a post implying there should be a MySQL table in the database called "phpfox_setting"

What's weird is I have no such table in my "live" production database. I do one have in a "dev" database. The live database was recently upgraded such that it is newer than the dev. (I know, did not test the update on the dev first -- was trusting in my backup).

Why can I not find a "phpfox_setting" table in the database?
Last update on April 27, 2014 by Fred Beall.
Donna(data66)
There should be one as you can't have a site without settings. It might be plural as I'm not looking atm. You will need to get with your developer for assistance to fix his add ons though as this forum is not for that. Modules are disabled via phpfox_module database table.
Fred Beall
Update: The reason I was not seeing the table was because there was "paging" happening, and I did not realize it. There were more tables than the interface was want to show at once.

I had restored from a backup before I realized that. But, not a problem.

I was able to edit the right field in the table, to turn off the secure settings.

Now I just need to report to phpfox.pro that the apps don't support this built-in feature of phpFox.
Donna(data66)
Thank you for posting your solution as others may also have the same issue.