Store Community Support Documentation
Paul Kellow
Hi all,
We have received many feedback about errors while upgrading to 4.5.3. Most of those cases are caused by lack of write permissions on "PF.Site/Apps" folder when upgrading phpFox site with "File System" FTP option. In this case, I have some quick solutions for you:
- Solution 1: Update permission 777 to "PF.Site/Apps" folders and its subfolders/files recursively. Then you can follow our guidance to upgrade again and can use "File System" option
- Solution 2: Skip step to upgrading apps with phpFox by unchecking all apps. You can still use "File System" option.
- Solution 3: If you still want to upgrade apps while upgrading phpFox, please use "FTP/SFTP" option which FTP account has write permission on "PF.Site/Apps" folder
If you have faced any other issues or other solutions while upgrading phpFox, feel free to share us here.
#1

After upgrading to 4.5.3b on my dev site I noticed that the Pages, Blogs and Marketplace modules no longer loaded content to guest users, even though the permissions in the admincp have been set for guests/non-logged in users to be able to view content on these modules.

Then on upgrading to the new standalone Pages app, while logged in as a user on the site, the new Papges module loads smoothly, but when I try to view the individual pages within the module, these do not load, but render as a blank webpage after I click refresh. On enabling debug mode, I get this error message:

"Fatal error: Class 'Pages_Service_Pages' not found in /home/------------/public_html/pfdev/PF.Site/Apps/core-pages/Controller/ViewController.php(66) : eval()'d code on line 1"

Your help with this will be greatly appreciated.

Thanks.

#2

The upgrade was from 4.5.2 to 4.5.3b

LM
#3

When trying to upgrade from 4.5.2 to 4.5.3b, it tried to start a completer re install. I am now restoring yesterdays backup.

Any ideas?

Thanks in advance.

LM

Spaninet
#4

When trying to upgrade from 4.5.2 to 4.5.3b, it tried to start a completer re install. I am now restoring yesterdays backup.

Any ideas?

Thanks in advance.

LM

 

What issue did you get?

LM
#5

It was trying to re install fresh instead of the upgrade.

#6

Same with me, it gives me message :

We have found that the following table(s) already exist:

Densy
#7

Hello Paul,

I got an error while trying to upgrade to v4.5.3b3.

I then see your post, followed Solution 1, I still get the error. What should I do? My site and mobile apps are all down.

I submitted a ticket for assistance.

Paul Kellow
#8

When trying to upgrade from 4.5.2 to 4.5.3b, it tried to start a completer re install. I am now restoring yesterdays backup.

Any ideas?

Thanks in advance.

LM

Perhaps  setting files have been occasionally removed while upgrading. We included solution for this case in 4.5.3b3. Have you tried with version 4.5.3b3 yet?