Store Community Support Documentation

I am using the latest version of PhpFox which I just downloaded today and did a fresh install. I should mention that I own more than one liscence and videos are working fine on my other website using an older version of phpfox that was upgraded a few months back. My ffmpeg is properly installed and the path I put in settings in the AdminCP is correct. Suggestions?

Day 9 still not fixed. Day 4 since paying phpfox for support and submitting a ticket to them. Issue still not resolved. Cannot upload videos, therefore I cannot open my website to the public.

in the interest of being fair i want to update this topic letting everyone know that phpfox has fixed my issue. i am now able to upload videos to my website so i am happy.

 

thank you phpfox.

in the interest of being fair i want to update this topic letting everyone know that phpfox has fixed my issue. i am now able to upload videos to my website so i am happy.

thank you phpfox.

 

Happy Ending:smiley::v:

Take no offense but all that ranting and your not going to tell us the how it was solved...I put a lot of time in reading all those post.  Please don't leave me stranded without the solution.  Was it software or was it the server or maybe the direction...please finish the story ߤ

1 Liked
 likes this.

Take no offense but all that ranting and your not going to tell us the how it was solved...I put a lot of time in reading all those post.  Please don't leave me stranded without the solution.  Was it software or was it the server or maybe the direction...please finish the story ߤ

Ԃ

you put "alot of time" into reading my posts but never once interjected to confirm that i was not the only one having this problem? sounds fishy but ok.

i cannot tell you exactly what phpfox did. what i can tell you is that i quickly realized that even tho i can upload videos and even tho all of my paramters are correct i am limited to uploading very short videos. php ini and ffmpeg is all set correct. admincp is set to allow 150M videos to be uploaded however any videos over 10M are not appearing in the videos section after being uploaded.

there is also a bug regarding the time and order of the videos. when i post a video it immediately says the video was posted 12 minutes ago when in fact it has only been on the site for mere seconds. the videos are also not appearing in the order they were uploaded.

the video app is buggy and unfit for use however i plan on making due because i have deadlines to meet.

Take no offense but all that ranting and your not going to tell us the how it was solved...I put a lot of time in reading all those post.  Please don't leave me stranded without the solution.  Was it software or was it the server or maybe the direction...please finish the story ߤ

A friend of mine ) of course this server.... The developers of PHPFOX do good modules and only working..... Check Your php version, to Increase client_max_body_size in nginx to 200 MB .. And all of You will work)

1 Liked
 likes this.

QueenMother305

Sorry, there was a lot to read so I had time invested and wanted to know the solution but I never indicated I had any issues myself :)  Glad you got it solved and hopefully comemore solves the other issues.

 

 

A friend of mine ) of course this server.... The developers of PHPFOX do good modules and only working..... Check Your php version, to Increase client_max_body_size in nginx to 200 MB .. And all of You will work)

 

i will try this and update this thread if it works.

 

 

i will try this and update this thread if it works.

 

my server is using apache not nginx. and according to my server admin my post max and other required settings are all set to 200M. it appears the video app is the problem. 

 

i am so fed up with this. i am literally at my wits end.

 

any genuine suggestions of value would be appreciated. i need to be able to upload longer videos. my server settings and the settings in my admincp are all set correct but it seems no videos over 10M can be uploaded. this is so frustrating.

On apache the same thing... Need to make corresponding settings of the server + php version. After these settings, the video app works fine.

1 Liked
 likes this.

On apache the same thing... Need to make corresponding settings of the server + php version. After these settings, the video app works fine.

Limitations Of Apache

Apache has a LimitRequestBody Directive to limit the size of the request. This Directive specifies the number of bytes from 0 (meaning unlimited) to 2147483647 (2GB) that are allowed in the request body. Also, if you have a website available over https, then it is necessary to adjust the value of SSLRenegBufferSize Directive.

Limitations Of Nginx

If you have a two-tier configuration of web servers: Nginx+Apache, then you need to adjust the client_max_body_size Directive. Sets the maximum allowed size of a client request body, specified in the field “Content-Length” header. Setting size to 0 disables checking of the size of the client request body.

----------------

In the end, I want to emphasize that the PHPFOX developers did a great app Video.... The Video app works fine..... Everything else depends on your server configuration and settings. Thank you for your attention! All a good day and mood! )

1 Liked
 likes this.

 

Limitations Of Apache

Apache has a LimitRequestBody Directive to limit the size of the request. This Directive specifies the number of bytes from 0 (meaning unlimited) to 2147483647 (2GB) that are allowed in the request body. Also, if you have a website available over https, then it is necessary to adjust the value of SSLRenegBufferSize Directive.

Limitations Of Nginx

If you have a two-tier configuration of web servers: Nginx+Apache, then you need to adjust the client_max_body_size Directive. Sets the maximum allowed size of a client request body, specified in the field “Content-Length” header. Setting size to 0 disables checking of the size of the client request body.

----------------

In the end, I want to emphasize that the PHPFOX developers did a great app Video.... The Video app works fine..... Everything else depends on your server configuration and settings. Thank you for your attention! All a good day and mood! )

 

While Phpfox makes good apps, there is a problem. I have used the same dedicated server for years, and the video app ran fine up until a month ago when I did a fresh install of my second liscence. I have spent countless hours, and $$$$ trying to fix something you claim is not broken. I have paid server administrators, paid phpfox for support, I have made sure all of the setting not only met minimums but have generously exceeded the minimums. I just had my server admin set my limit request body to ZERO for unlimited. Nevertheless I still can not upload videos exceeding 10M despite my phpfox video app settings for the user group being set at 150.

 

 

While Phpfox makes good apps, there is a problem. I have used the same dedicated server for years, and the video app ran fine up until a month ago when I did a fresh install of my second liscence. I have spent countless hours, and $$$$ trying to fix something you claim is not broken. I have paid server administrators, paid phpfox for support, I have made sure all of the setting not only met minimums but have generously exceeded the minimums. I just had my server admin set my limit request body to ZERO for unlimited. Nevertheless I still can not upload videos exceeding 10M despite my phpfox video app settings for the user group being set at 150.

 

I stand corrected. I believe your suggestion may have worked. It appears if you have multiple accounts on the same server ( like in my situation 2 different phpfox sites ) you have to set limit request body for each account seperately. I will continue testing and update this post to help anyone else who may be having this same problem.

UPDATE: After several hours of testing I can confirm the app is now functioning as it should. The problem all along was the "LimitRequestBody Directive". Had I known this I could have spared myself weeks of frustration. Perhaps phpfox should include this in the tutuorials as an option for anyone who has had the same problem I experienced. All parameters per phpfox tutuorial were set correctly however since this option was not mentioned it was overlooked as the root of the problem. 

 

Many thanks to ComeMore for providing the solution to my problem.

just another update. phpfox staff updated my support ticket yesterday and informed me that the issue was not the "LimitRequestBody Directive". they told me there was in fact a problem with their app. they uploaded the patch to my site. and it will be available to all of you in the next release.

1 Liked
 likes this.