Store Community Support Documentation

when instaling the phpfox, we must change the all file permission to 777, it has to do to all the files in that folder, but my hosting dosent have that option to do it in a one command, they saying i have to do it manually one by one ?

is there anyway ? plz help me

Spaninet
#1

when instaling the phpfox, we must change the all file permission to 777, it has to do to all the files in that folder, but my hosting dosent have that option to do it in a one command, they saying i have to do it manually one by one ?

is there anyway ? plz help me

 

If you have acces to shell you can change folder permmissions like this:

sudo chmod 777 ./PF.Base

 

spirog
#2

when instaling the phpfox, we must change the all file permission to 777, it has to do to all the files in that folder, but my hosting dosent have that option to do it in a one command, they saying i have to do it manually one by one ?

is there anyway ? plz help me

 

please dont do that...  you only need 4 folders to 0777

https://docs.phpfox.com/display/FOX4MAN/Installing+phpFox

 

to install only 4 need 0777  

 

Make your phpFox site more secure

This is SHOULD HAVE step to make your site more secure but it requires technical knowledge about the server system. Therefore, please feel free to contact your system admin or hosting provider for help if you are not familiar with server stuff.

You should grant permissions of files and folders to "webserver user" account as below:

Note: "webserver user" is a user account on server which can run web or PHP command. In Linux system, this user is usually nginx or apache or www-data.

 

spirog
#3

All files under PF.Base/file/..... will have correct permissions when you clear cache

 

 

Last update on September 2, 7:15 pm by spirog.
spirog
#4

Capture.JPG

Attachments
Capture.JPG 57.38 Kb . 20 Views
Spaninet
#5

 

 

If you have acces to shell you can change folder permmissions like this:

sudo chmod 777 ./PF.Base

 

 

Use the above command only if you know how SSH and Linux permissions work.

JohnJr
#6

I have mentioned this before, and I don't know if I just don't understand it or the help page is wrong.  The help page is located at https://docs.phpfox.com/display/FOX4MAN/Installing+phpFox

and it says...

When I read this...I see that although PF.Base/file folder is 777 that all folder inside PF.Base/file would be 755 except the cache folder which they indicate should be 777.  Is this correct?  If not then why point out the cache folder as all would be 777 if you made the main folder 777.   Now also the directions indicate that PF.Site/flavors is 777 so does that mean PF.Site is also 777 because I though you can't have more permission in a subfolder than the main folder.  Also...not sure how the folder APPS is affected if it does not have 777.  This has always been confusing....can't you just provide us a bash script to do it the correct way.  

JohnJr
#7

I did find this bash script...but it is base off the old version so don't use it.  If I get the correct answer for above I could change it.

find file/ -type d -print0 | xargs -0 chmod 0755
find file/ -type f -print0 | xargs -0 chmod 0644
find include/ -type d -print0 | xargs -0 chmod 0555
find include/ -type f -print0 | xargs -0 chmod 0444
find static/ -type d -print0 | xargs -0 chmod 0555
find static/ -type f -print0 | xargs -0 chmod 0444
find theme/ -type d -print0 | xargs -0 chmod 0555
find theme/ -type f -print0 | xargs -0 chmod 0444

 

JohnJr
#8

Bringing it to the top...would like a response from phpfox :)

JohnJr
#9

To the top again...still waiting for a response from phpfox.

David Nguyen
#10

Hi JohnJr,

Thanks for your question, please try apply my guide below. If it is work, we will update document again.

## Change folder permissions and ownership to "webserver user". In Linux system, this user is usually nginx or apache or www-data. Example: $USER = apache

$ sudo chown -R $USER:$USER SITE_FOLDER/

## Grant permissions of files and folders

# All folders have permission 755

$ find SITE_FOLDER/ -type d -exec chmod 755 {} \;

# All files have permission 644

$ find SITE_FOLDER/ -type f -exec chmod 644 {} \;

Best Regards,

David Nguyen.

JohnJr
#11

Thanks for the response...I will check this out.  So...when you upgrade or install a new app do you need to change these settings?

JohnJr
#12

Plus you didn't mention anything about..

            PF.Base/file

            PF.Base/file/cache
            PF.Site/flavors

Do these not have to be 777 now?

David Nguyen
#13

Thanks for the response...I will check this out.  So...when you upgrade or install a new app do you need to change these settings?

Hi JohnJr,

You no need change these settings.

Note*: You need use "FTP User name" like with "webserver user" when upgrade Core or upgrade app.

About folder permissions, I have updated the guide, please check here:  https://docs.phpfox.com/display/FOX4MAN/Installing+phpFox

Best Regards,

David Nguyen.

Last update on December 8, 10:36 am by David Nguyen.