Store Community Support Documentation

I have set up the facebook login according to the instruction. However, I am getting the error :

URL Blocked: This redirect failed because the redirect URI is not whitelisted in the app’s Client OAuth Settings. Make sure Client and Web OAuth Login are on and add all your app domains as Valid OAuth Redirect URIs. 

 

"Use Strict Mode for Redirect URIs" is set to  Yes but the Yes is shaded. Can anyone help.

"Client OAuth Login" is set to yes and the rest to no.

phpFoxer
#1

Both Client OAuth Login and Web OAuth Login should be enabled.

Also try to copy your website URL from address bar of your browser, remove everything from Valid OAuth redirect URIs field and paste copied value again.

Attachments
#2

I have set up the facebook login according to the instruction. However, I am getting the error :

URL Blocked: This redirect failed because the redirect URI is not whitelisted in the app’s Client OAuth Settings. Make sure Client and Web OAuth Login are on and add all your app domains as Valid OAuth Redirect URIs. 

 

"Use Strict Mode for Redirect URIs" is set to  Yes but the Yes is shaded. Can anyone help.

"Client OAuth Login" is set to yes and the rest to no.

There is no way to turn off "Use Strict Mode for Redirect URIs". Does anyone know how to turn it off ?

aaronmskater
#3

you need to add your log in url to facebook whitelist on your app account. I had this issue too until I added proper url links

#4

The problem is facebook doesn't allow to disable Use Strict Mode for Redirect URIs. Is it just me that can't turn it off

#5

The problem is facebook doesn't allow to disable Use Strict Mode for Redirect URIs. Is it just me that can't turn it off

https://stackoverflow.com/questions/49412342/how-to-turn-off-use-strict-mode-for-redirect-uris-in-facebook-app

Since March it seems Facebook doesn't allow it.

Jonathan Mitchell
#6

i can toggle mine on and off

Rune
#7

Today, facebook login has stopped working. The following errors appear at login:

"URL Blocked: This redirect failed because the redirect URI is not whitelisted in the app’s Client OAuth Settings. Make sure Client and Web OAuth Login are on and add all your app domains as Valid OAuth Redirect URIs."

What are the settings?

Rune
#8

you need to add your log in url to facebook whitelist on your app account. I had this issue too until I added proper url links

What is the proper url links? - I found it, thanks for the help!

Problem with "Given URL is not whitelisted in Client OAuth Settings"? This is the right URL:

yoursite.com/fb/auth/

Attachments
Facebook Login.png 48.99 Kb . 65 Views
Last update on March 25, 11:10 am by Rune.
#9

I've changed the "Given URL is not whitelisted in Client OAuth Settings" information to reflect:

mysite.com/fb/auth/

but all I get back from my website after clicking the FB login button is:

Oops! Something went wrong

#10

I have this problem too

mysite.com/fb/auth/

get error 500

already follow 

https://docs.phpfox.com/display/FOX4MAN/Setting+Up+the+Facebook+App

 

 

Does anyone know how solve this problem  ?

Vivian
#11

I can not reproduce this issue on my local site. Please submit us a support ticket and we will check on your site.

#12

Hi

 

Vivian I already submit ticket

 

Thanks