Hi everyone,

I was trying to build my first app on PHPFOX by following the tuttorial: 

https://docs.phpfox.com/display/FOX4DEVDOC/Writing+Your+First+App

But I beleive there is an error in the tuturial, even if you coppy the same code. After following the steps and pasting the code in the file start.php, in theory if you go  yoursite/index.php/to-do-list you must see the page of the app, but what I'm getting is the error 500 (not only on that page but on entire website).

 

Please let me know what is wrong, and update the tuttorial base if theres some errors.

Thank you

Be the first person to like this.
Rune

Same problem here, tried the same and got error 500..

Be the first person to like this.
YouNetCo

Hi there,

Can you please share the log of the error you are currently having?

Cheers,

YouNetCo

Be the first person to like this.

error
ParseError: syntax error, unexpected 'namespace' (T_NAMESPACE) in /var/www/vhosts/mydomain.com/httpdocs/PF.Site/Apps/TodoList/start.php:3


Stack trace:
#0 /var/www/vhosts/mydomain.com/httpdocs/PF.Base/include/init.inc.php(273): Core\App->__construct()
#1 /var/www/vhosts/mydomain.com/httpdocs/PF.Base/start.php(85): include('/var/www/vhosts...')
#2 /var/www/vhosts/mydomain.com/httpdocs/index.php(9): require('/var/www/vhosts...')
#3 {main}

Be the first person to like this.
YouNetCo

Hi there,

We created quick video to demonstrate the steps to build first app as in the docs.

Please follow and let us know if you can figure out something.

https://youtu.be/UXFCgVtFRYc

Cheer,

YouNetCo

Be the first person to like this.

First of all thank you for the video tutorial, I really appreciate this.

I did exactly the same but the problem persist, I was using the version 4.6. 

 

I decide to delete the app and make an upgrate to 4.6b2, the upgrate went well, the website is working.

I start from the beggining the tutorial for building the FIRST APP, but as soon as I'm enabling the Techie Mode (by pasting the code 

 

define('PHPFOX_IS_TECHIE', true);

Inside the file debug.sett.php

My website is not available  

 

It's hard to understand why because I'ts i didn't change the configurations or the files, just follow the instructions.

Here is my system information: 

Even if i downgrade the php version, the problem is the same.

 

Thank you for the support

Last update on May 9, 2018 by Neil.
Be the first person to like this.

.

Last update on May 9, 2018 by Petrutz.
Be the first person to like this.

P.S.

(Theres a bug in this forum when you put special container)

Last update on May 9, 2018 by Petrutz.
Be the first person to like this.
David phpFox

Hi there,

Please export your TodoList app and send it for me. I will install it on my site and help you find the problem.

Best Regards,

David Nguyen.

Be the first person to like this.

On clean install everything worked as it should,

I'll update the setings as It was before, also install the same modules. If I'll find the problem why wasn't working I'll let you know guys.

Thanks to everyone.

Petru

David phpFox

Hi Petrutz,

I have checked your Home app you have sent for me. You have missed 1 step (set alias for app): https://docs.phpfox.com/display/FOX4DEVDOC/Writing+Your+First+App

Please check the screenshot.

I have tried update it and check. It's working.

Best Regards,

David Nguyen.

Last update on June 4, 2018 by David phpFox.
NetworkCycles

Is this tutorial (fixed) working now?

https://docs.phpfox.com/display/FOX4DEVDOC/Writing+Your+First+App

 

 

Be the first person to like this.

Follow the instructions of David, and make sure that you have clean your cache form backend and your browser.

Max Peterson

Hi everyone,

I'm new to phpFox and have been going through the documentation. I too have been following the tutorial for writing my first App and haven't been able to determine the cause of a 500 error I've been receiving when I go to: domain/index.php/to-do-list/ . I have gone through the instructions, checked and rechecked my code, reviewed this thread a couple times, as well as watching the video but just haven't been able to make any progress. Any suggestions/help is appreciated. Thanks.

Be the first person to like this.