Store Community Support Documentation

Hello the video upload function is not for me

I chose the upload method FFMPEG also because path set to

but unfortunately no videos can be uploaded

debug enabled and get this error: define ('PHPFOX_DEBUG_ON_SCREEN', true);

 

do you have a tip on what that is?

Attachments
error.JPG 38.84 Kb . 24 Views
Topics: video, error, debug, define
spirog
#1

do you have ffmpeg installed ? also did you setup in video app settings /usr/bin/ffmpeg or /usr/local/bin/ffmpeg 

 

Attachments
ffmpeg setup.PNG 129.99 Kb . 19 Views
spirog
#2

yes and also make sure you add cron job for cron.php it should be in your public_html directory

 

go to cpanel if you have and add cron every 5 mins and add in cron field:

/usr/local/bin/php /home/username/public_html/cron.php >/dev/null 2>&1

 

Attachments
Last update on July 12, 2:57 am by spirog.
spirog
#3

also you need to make sure you have crons setup as Paul mentioned and also have ffmpeg installed and set

to find out if /usr/bin/ffmpeg or /usr/local/bin/ffmpeg

you need to use command line ssh

type: which ffmpeg

this will give you correct path

also type: ffmpeg

this will give you version number of ffmpeg.

JUST FYI: ffmpeg must be 3.0 or higher to work with phpfox

#4

hello spirog, thanks for your answer

I have checked all setting, the path is correct, uploading method is also set to ffmpeg

I had no attitude in cronjob that I have changed (see picture)

the Ffmpeg version is displayed to me so the path must be correct?

I still can not upload any videos and the error will still be displayed "define ('PHPFOX_DEBUG_ON_SCREEN', true);"

thanks for your help

Attachments
methode.JPG 38.23 Kb . 14 Views
path.JPG 20.76 Kb . 11 Views
cron.JPG 101.08 Kb . 14 Views
ffmpeg utilitties.JPG 59.69 Kb . 12 Views
spirog
#5

hi when you added in cron /usr/local/bin/php /home/username/....   is username what you actually wrote or did you change this to your username account name ?

( sorry for the dumb question just making sure) also to find your path for cron you should go to admincp>>settings>>cron 

you should see similar

Cron Job

PATH for setting up cron jobs

/home/johnny/public_html/cron.php

Copy the PATH then follow the instruction at here to set up cron jobs for your phpFox site.

this will be your PATH that is what you would enter after /usr/local/bin/php /home/johnny/public_html/cron.php >/dev/null 2>&1

 

if yours is correct should work ?

ALSO what server you have centos 6 centos 7

what php version?

 

did you go to admincp>> Apps>> Installed>> scroll down to Videos and click on it

then click on >> User Group Settings >> administrator 

User Group Settings

 

select dropdown  User Group Settings >> Registered User 

now change Can share/Upload a video to YES 

and again change how much to allow upload 100 ? 200 ? 300 ? etc and save

 

now try to upload video

if all fails you ask you host how much do they allow for upload limit 

PHP is usually set as 2mb only as default so you might have to change your php.ini value for upload to more than 2mb or if you use .htaccess you can set it there

my example of htaccess file 

# START phpFox Rewrite
Options -Indexes
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(file)/(.*) PF.Base/$1/$2
RewriteRule ^themes/default/(.*) PF.Base/theme/default/$1
RewriteRule ^(static|theme|module)/(.*) PF.Base/$1/$2
RewriteRule ^(Apps|themes)/(.*) PF.Site/$1/$2
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . index.php [L]
# END phpFox Rewrite
# php -- BEGIN cPanel-generated handler, do not edit
# NOTE this account's php is controlled via FPM and the vhost, this is a place holder.
# Do not edit. This next line is to support the cPanel php wrapper (php_cli).
# AddType application/x-httpd-ea-php70 .php .phtml
# php -- END cPanel-generated handler, do not edit# BEGIN cPanel-generated php ini directives, do not edit
# Manual editing of this file may result in unexpected behavior.
# To make changes to this file, use the cPanel MultiPHP INI Editor (Home >> Software >> MultiPHP INI Editor)
# For more information, read our documentation (https://go.cpanel.net/EA4ModifyINI)
php_flag display_errors Off
php_value max_execution_time 7200
php_value max_input_time 3600
php_value max_input_vars 10000
php_value memory_limit 768M
php_value post_max_size 800M
php_value session.gc_maxlifetime 2880
php_value session.save_path "/var/cpanel/php/sessions/ea-php70"
php_value upload_max_filesize 600M
php_flag zlib.output_compression Off
# END cPanel-generated php ini directives, do not edit
Last update on July 17, 10:55 pm by spirog.
spirog
#6

here is file

Attachments
htaccess.zip 891 b . 5 Views
Last update on July 17, 10:49 pm by spirog.
spirog
#7

Also try turn off debug .and see if video works. 

One.more thing. The reason I ask about centos 6 or centos 7 I have a simple ffmpeg install.sh on GitHub that I use that works and you can change version numbers of ffmpeg. Installs mp4box ffprobe and more. I will get link and post it here if you need to try to see if you have all the correct codecs installed now or the ffmpeg installer works.

It's for centos 7 I also havecPanel and it works no problem. But works right out of the box, even without cpanel

Just follow 3-4 easy steps and you will have ffpmeg

Last update on July 18, 5:40 am by spirog.
spirog
#8

Here is the link 100% working and it's free centos 7 only please read how to change ffmpeg version numbers .Really easy. 

 

https://github.com/spirogg/ffmpegtoolkit

spirog
#9

Any luck getting it working my friend ?