Store Community Support Documentation

Installed the ssl certificate via cpanel. Https is enabled and working correctly. But site no longer sends out emails. Why? My members are not receiving link to verify accounts. This is a huge problem for me.

Last update on July 11, 5:07 pm by QueenMother305.
QueenMother305
#1

issue resolved for the moment by switching to tls

spirog
#2

in mail settings did you try :

 

1) Send Mail Method: SMTP

Warning This is an important setting. Select a wrong option here can break the site or affect some features. If you are at all unsure about which option to configure, use the default value or contact us for support.

Check ssl certificate of your SMTP host name. If it does not use valid certificate, email can't be sent     ON

3) SMTP Authentication ON

4) Secure with SSL or TLS ? SSL

465

save settings - obviously I know you have uesrname password mail.yourdomain.com etc setup

this worked for me with cPanel and Auto ssl : that cPanel provide for free :)

hope this helps

 

Spiro

Last update on July 12, 2:56 am by spirog.
spirog
#3

also did you set up SSL settings to ON

Attachments
SSL settings.PNG 210.53 Kb . 7 Views
JohnJr
#4

Also, I know under Plesk which is like cpanel that under hosting settings I checked SSL/TLS support as well as seo-safe 301 direct from HTTP to HTTPS.

QueenMother305
#5

I use sendgrid but for some reason it stopped working when i added ssl to my site.

QueenMother305
#6

in mail settings did you try :

 

1) Send Mail Method: SMTP

Warning This is an important setting. Select a wrong option here can break the site or affect some features. If you are at all unsure about which option to configure, use the default value or contact us for support.

Check ssl certificate of your SMTP host name. If it does not use valid certificate, email can't be sent     ON

3) SMTP Authentication ON

4) Secure with SSL or TLS ? SSL

465

save settings - obviously I know you have uesrname password mail.yourdomain.com etc setup

this worked for me with cPanel and Auto ssl : that cPanel provide for free :)

hope this helps

 

Spiro

 

all of that was set correctly. however i should mention i use sendgrid as my mail server. not sure what the issue is, but it worked fine until i added ssl to my site. then it stopped. i had all my parameters set correctly.

spirog
#7

@QueenMother305

 

You need to ask sendgrid if they have enabled ssl or just tls based on your plan. Or when you entered your website address in there setup.

Is it :

http:// your domain.tld

or is it :

https://your domain.tld

Maybe if you go back to your mail settings in sendgrid see if you domain has https if not try to change to https:// your domain.tld and change admincp again to ssl and see if it works. :) Hope this will help .

spirog
#8

Sorry double posted somehow. You can disregard this. 

Last update on July 13, 12:36 am by spirog.