Store Community Support Documentation

I am trying to upgrade 4.7.0

But i am getting following error:

 Call to undefined method Theme_Service_Theme::isInDnDMode() 

Paul Kellow
#37

Upgraded my PHP Version to 7.2 and a fresh installation works fine for me.

Upgrading my dev site was successfully completed, then when trying to access the site; I got the 500 error message and cannot log in to the admincp as well.

What's next?:persevere:

I guess there are some 3rd-party apps which aren't compatible with phpFox 4.7.0 and are still enable on your site after upgrading. Please try to disable all 3rd-party apps, rebuild core theme, clear cache and then check again.

In order to have exact answer to you, please contact us via Ticket System. We can help you investigate the issue.

AFRIKA
#38

Solution thaht worked for me;

Delete custom flavor that you've created, delete cache folder, login...

vktechnology
#39

Is it possible to disable 3rd-party apps  via configure file ?

Is it possible to rebuild core theme without login to admincp ?

#40

 

I guess there are some 3rd-party apps which aren't compatible with phpFox 4.7.0 and are still enable on your site after upgrading. Please try to disable all 3rd-party apps, rebuild core theme, clear cache and then check again.

In order to have exact answer to you, please contact us via Ticket System. We can help you investigate the issue.

 

i done everything also disabled core apps too but still the issue.

i see there lot of people having this issue and phpfox team are so still for this issue!

i have created a support ticket too and waiting more than 4 days!

thanks phpfox team!

Scheinwelt-Media
#41

if you are using a material based theme try to copy the file

PF.Site/flavors/material/html/block.html.php

to

PF.Site/flavors/yourtheme/html/block.html.php

 

that should solve the error from the first post. dont forget to make a backup of the original file.

you can also just delete all references to the dndmode in this file manually.

Last update on October 28, 5:09 pm by Scheinwelt-Media.
Paul Kellow
#42

Is it possible to disable 3rd-party apps  via configure file ?

Is it possible to rebuild core theme without login to admincp ?

You can disable 3rd-party apps in the database, [dbprefix]_apps table.

Due to security risk, we don't provide any way to rebuild Core theme without logging in AdminCP. 

Paul Kellow
#43

Hi all,

We just quick released new version of Activity Points app to fix the critical issue when creating Point package in AdminCP. This issue happens when the server is using PHP 7.x

Btw, we have some recommendations for the phpFox upgrade here: https://www.phpfox.com/blog/2018/upgrade-phpfox-4-7-0-the-right-way/

Looking forward to your thoughts

Bui Chi Cong
#44

 

Thanks Paul. I updated the Activity Points application to version 4.7.1. However, the problem I encountered has not changed. Activity Points are not working properly. The admin page is not visible. Please guide me how to fix this

Hi all,

We just quick released new version of Activity Points app to fix the critical issue when creating Point package in AdminCP. This issue happens when the server is using PHP 7.x

Btw, we have some recommendations for the phpFox upgrade here: https://www.phpfox.com/blog/2018/upgrade-phpfox-4-7-0-the-right-way/

Looking forward to your thoughts

vktechnology
#45

Hi aAll

1) I have successfull update to phpfox4.7 on my live site without problem

after follow Upgrade phpFox 4.7.0 the right way

2) I feel phpFox4.7 is load faster than phpfox 4.6

 

Last update on November 1, 8:51 pm by vktechnology.
Osii
#46

Hi! I got a problem and need to reinstall. This is how i got it working:

If you are using Material Template, before upgrading do this:

Select Bootstrap theme before upgrade. After installation, go to Theme selection and edit your material theme. In my case i've got a 500 message on the right side window and created a new copy theme from material. This is the only way i got it working (i tried to copy and paste all css,html and java but the theme was still problematic).

Other issue i faced was with redis cache and php v7.2. So before upgrading, i've changed the cache to file system as well. Isn't redis compatible with php v7.2 or the problem is with my host?

 

Thanks.

AFRIKA
#47

Pore coding... This is the solution fir the last 5 upgrades... Since then, I use original theme...

Bui Chi Cong
#48

Hi all,

We just quick released new version of Activity Points app to fix the critical issue when creating Point package in AdminCP. This issue happens when the server is using PHP 7.x

Btw, we have some recommendations for the phpFox upgrade here: https://www.phpfox.com/blog/2018/upgrade-phpfox-4-7-0-the-right-way/

Looking forward to your thoughts

 

Thanks Paul!

However, the Activity Points application is still buggy.

At my site, the user's language setting is English. How To Earn can work well. I Attach photo 1 to illustrate

 When choosing a language other than English, the page displays incorrectly. Can not expand items such as: blog, event, image .... to see point rules. I enclose Figure 2 to illustrate.

I even watched the demo of phpfox at the following link: https://v4.phpfox.com/activitypoint/information/ Whether to install user language is English (US) or English (Kingdom). How To Earn pages are not displayed correctly.  Can not expand items such as: blog, event, image .... to see point rules

Fatih YILMAZ
#49
can't update. can someone help me? I applied all of the instructions. no update.
#50

Same issue again with 4.7.1

AFRIKA
#51

You MUST switch to default theme before upgrading! Atleast that is how i works for me...