Store Community Support Documentation

Whenever we try to use php 7.x , the site page goes white ! Presently we are using php 5.6. What could be the issue ? What is the major benefit of using php 7.x ?

Topics: php verison
Be the first person to like this.
Paul Kellow
#1

Hi Naresh,

PHP 7.x has numerous improvements, especially its performance is much faster in comparison with PHP 5.6. And, phpFox has been updated to work well on PHP 7.x. 

If you can access to AdminCP, you can try to disable all 3rd-party apps and check again first. If the blank issue still occurs then, you can submit a ticket in Client Area. We are willing to help take further investigation.

Scheinwelt-Media
#2

check for mysqli in your server.sett.php file

Be the first person to like this.
#3

Kindly elaborate it a bit as I have very basic knowledge of server.

Be the first person to like this.
Scheinwelt-Media
#4

in server.sett.php check this line:

$_CONF['db']['driver'] = 'mysqli';

one of my old sites had this issue after updating to one of the latest phpFox versions. the site was installed on php 5.6 and the driver was 'mysql' instead of 'mysqli'. After adding the 'i' it worked perfect.

#5

I checked. Its mysqli in the file. These must be something else.

Be the first person to like this.
Scheinwelt-Media
#6

you cancheck the log file or enable debug mode to check for errors: https://docs.phpfox.com/display/FOX4DEVDOC/Developer+with+Debug+Mode+Enabled

Be the first person to like this.
Paris
#7

Back up entire DB & customizations.

Re-install.

Import all Modules DB tables.

It worked for me.

I hope it works for you.

php 7+ has HUGE advantages. I noticed a huge speed gain using opcache , redis, and all the goodies php7 has.

note: this wont fox phpfox stupid issues though like slow speed, horrible app system and all related to phpfox.

Last update on December 1, 5:08 pm by Paris.
Be the first person to like this.
#8

try to update your .htaccess to default

Be the first person to like this.
#9

OK will try

Be the first person to like this.
mrfenix
#10

Did you have any success with this? I faced the same issue.

Be the first person to like this.
#11

NO help till now ! Waiting :) Somybody asked me to send him the error message , but when the site is not running on the apache server , its not possible.

Be the first person to like this.
#12

Its possible you're missing something you have installed for php5 if that was you last version that you havent got installed for php7 

 

Anyhows, this is my htaccess modify it to suit your needs 

i use php7.2 

check developer console in your browser, it may give an indication as to whats wrong. 

 

Attachments
my-htaccess.zip 1.03 Kb . 6 Views
Last update on August 25, 4:16 pm by Vanucci.