Store Community Support Documentation

https://i.gyazo.com/c57fedfb053c6316b4c4a1e8d34c1a30.mp4

 

as you can see in this clip, when i go to install its stalls out and never changes, 

file permissions are correct, restarting it does not resolve the issue and my site is stuck in upgrade mode. 

Be the first person to like this.
#1

update, i have tried the 3 solutions on the how to 

 

While upgrading to version 4.5.3 or later, you may face errors and most of those cases are caused by lack of write permissions on "PF.Site/Apps"; folder when upgrading phpFox site with "File System" FTP option. In this case, we have some quick solutions for you:

- Solution 1: Update permission 777 to "PF.Site/Apps"; folders and its subfolders/files recursively. Then you can follow our guidance to upgrade again and can use "File System" option

- Solution 2: Skip step to upgrading apps with phpFox by unchecking all apps. You can still use "File System" option.

- Solution 3: If you still want to upgrade apps while upgrading phpFox, please use "FTP/SFTP" option which FTP account has write permission on "PF.Site/Apps"; folder

If you have faced any other issues or other solutions while upgrading phpFox, feel free to share us here.

 

None of these worked for mew unfortunatley

#2

To not have had a reply to this in almost 24 hours is rather bad people. 

Be the first person to like this.
#3

Why does it take so long to update a website with the phpfox new files?  It takes over 6 hours to updates files by FTP.  That is just ridiculious.  I wish that PHPFox would have only the necessary changed files needed to upload and update instead of all of the files.  This is becoming really BAD for update your website and having it to be down for over 6 hours just for some update.

Be the first person to like this.

I think its an .htaccess bad config file.  If you dont have .htaccess file in your root directory, please create one, with the following code:

<IfModule mod_rewrite.c>
  RewriteEngine On
  RewriteBase /
   
  RewriteRule ^static/ajax.php index.php
  RewriteRule ^themes/default/(.*) PF.Base/theme/default/$1
  RewriteRule ^(file|static|theme|module)/(.*) PF.Base/$1/$2
  RewriteRule ^(apps|themes)/(.*) PF.Site/$1/$2
   
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteRule ^(.*) index.php/$1
 

</IfModule

 

Save it, then look in your server for "sec_mod" and disable it just to install the script. 

 

Be the first person to like this.
#5

Hi Vanucci,

We would like to confirm that there are many cases related to this issue so kindly open a new support ticket from your client area with your server information so that our technical team can investigate and give you a solution for this issue.

Best regards,

Be the first person to like this.