When my users sign up, they are asked for their birth year. The closest birth year can't be higher than 2017. 

In my case, it is relevant because my website is about pets. Some pets were born recently, like in 2020... When i go to Settings to change that, I can set many numbers, but never higher than 2017... then I get an Error about the range, and the number being higher than the birth year... I can't find where to fix that.

Thank you.

Be the first person to like this.

This is set in admincp . Not sure why the setting needs to be there, but sure... :)

Go to admincp->members->manage settings

Search for 'date of birth (end)'

Be the first person to like this.

Thanks for your response. The problem is... I found this setting but it cannot be changed to any number over 2017. Somehow, it has this limit. People don't notice this bug because most users are over 3yr. olds. But in my case, (I deal with pets), it makes a difference.

Thank you.

Be the first person to like this.

Deleted.

Last update on February 18, 2021 by Carlos Osterling.
Be the first person to like this.

Deleted.

Last update on February 18, 2021 by Carlos Osterling.
Be the first person to like this.

Unfortunately, this is hard coded into a file as well. 

in PF.Base/module/user/include/plugin/validator.admincp_settings_user.php ;   , change the references from 2017 to 2021

Just keep in mind, you'll have to keep changing that, so it might not be a bad idea to keep THAT reference somewhat high (say 2050, etc), and just change the year in admincp when you have to

Again, I have no clue why this is even a setting, or required, but this is the way it is with things sometimes.

JohnJr

Yes...that shouldn't be in the code that way as that is a bug for sure.  Now each upgrade you will have to fix it manually.

Thank you so much. I found it and fixed it. I wouldn't have never found it.

Be the first person to like this.