Hello!

I want to disable this signup form that show in home page for visitors, where can i disable and off  this form ( not showing for visitors )

Thank you verymuch

Be the first person to like this.
JohnJr

I will be looking at that this week.  Because I noticed lately that is showing up mostly on Google but also on Edge  (never on FireFox) and I have a "invite only" community.

So if phpfox does not respond to you, I will be looking at hacking the code to get rid of it this week.

Vinny

Hi Hasan,

In order to turn off the signup form that show in your visitor home page, please try to follow the setting: From AdminCP>Registration Settings>Toggle the fuction "Allow User Registration" off.

Hope the above information is helful for you :))))

Vinny.

JohnJr

Vinny, I am not sure but looking at his first comment he said to disable the signup form not disable registration.  Like currently on my website which is invite-only (I am assuming his site is an invite-only as well because most sites you want users to register somehow)...this sign-up is showing up on certain browsers.   When I turn off "Allow User Registration" I am unable to invite new users.

Hannah

@Hi hasan,

If you just want to hide this block on the landing page, please go to admincp > Appearances > Blocks > Select page = [Visitor Landing Page (core.index-visitor)] > and disable the block named [User SignUp for Guests].

Hope it can help you.

Regards,

Hannah

Last update on June 2, 2021 by Hannah.
Be the first person to like this.
JohnJr

Hannah,

Your on a roll today!  The only problem for me it never use to show the register form and if the above doesn't help Hasan maybe he is in the same situation as I am.  First it started with Google Browser and now with Microsoft Edge.  I have an invite only website and when you click the email invite link it goes to a different register form which is perfect.  But, not too long ago when you went to my home page it said it was an invite community with text box for your email invite and now it shows the registration box always on those two browsers.  When I shut off that block on the vistor's page, then people who don't click the link and go to the home page has no place to put their invite email.

Here is two screen shots of my site (top) is Firefox and bottom is Google. 

 

If you get this far on this long post...congrats.  Question:  why didn't the CSS guys just add 20 pixels more on the bottom of this box so the sign up button isn't partial hidden and you have to attempt to use that skinny can't even tell its a scroll bar...scroll bar : )

Your still a genius though :)

Hello!

Thank you for all 3 , Yes I do n,t want to disable registration , only want to hide signup form.

I went and  disable from address below

admincp > Appearances > Blocks > Select page = [Visitor Landing Page (core.index-visitor)] > and disable the block named [User SignUp for Guests].

 

And  will see what will happen and say you

Mersi

Hanna order worked !

Thank you  for all and thank you for Hanna

Be the first person to like this.
JohnJr

That is great...hopefully she can help issues as well...she is on roll of greatness today :)

Be the first person to like this.

We aso had this issue , signup bottom partially shows

 

admincp > Appearances > Blocks > Select page = [Visitor Landing Page (core.index-visitor)] > and disable the block named [User SignUp for Guests].

 

In  that  address  also  I  was  ;   there was  setting and options for signup form . As  image below 

 

On  mobile  on  tablet  on  PC ...   we can choice

Be the first person to like this.
JohnJr

Is anyone else having this issue with a invite-only website?

Be the first person to like this.
JohnJr

Is anyone else having this issue with a invite-only website?

Be the first person to like this.
Hannah

We aso had this issue , signup bottom partially shows

 

 

'===> We would like to ask what theme that you are using so we can check this issue in our local environment?

Thank you

 

Be the first person to like this.
JohnJr

It is the material theme and it comes and goes.  I don't get it.  It never happens on Firefox but edge and chrome pop up with the registration form when I have an invite-only website.  I am going to try to check daily and see if there is something I do differently because today it is working correctly on all three browsers.  Very weird.

Be the first person to like this.