Im not sure what has changed with users pics in phpfox but I recently upgraded after many years of being on an older version of fox.

When I try to tweet my members profiles or pics to twitter it wont populate a twitter card or even a pic. Just a link. Does anyone know of a way to fix this?

Be the first person to like this.
JohnJr

I don't know if this makes a difference as I have not used Twitter since 2009 and I don't know where in phpfox you are posting it.

But if you share a link then you only get the link and the title.

If you embed a tweet then if I remember correctly, you get the actual tweet with the image and the name of the Twitter account on the bottom...if it is still the same.

Be the first person to like this.

I don't know if this makes a difference as I have not used Twitter since 2009 and I don't know where in phpfox you are posting it.

But if you share a link then you only get the link and the title.

If you embed a tweet then if I remember correctly, you get the actual tweet with the image and the name of the Twitter account on the bottom...if it is still the same.

 

Im talking about when I social share a phpfox members pic or prpfile to twitter, it doesnt populate the image to twitter

JohnJr

Sorry...that sucks.

Be the first person to like this.

Sorry...that sucks.

support is going to look at it

Be the first person to like this.
Hannah

Hi eazydoesit,

Could you describe the steps that you shared on Twitter? Does it simply post a tweet with phpFox link of user profile or user member pic?

Hannah 

 

Be the first person to like this.

I remember it pulling the picture into the share, too.

Be the first person to like this.

Hi eazydoesit,

Could you describe the steps that you shared on Twitter? Does it simply post a tweet with phpFox link of user profile or user member pic?

Hannah 

 

I go to member image, click the twitter share icon. It pulls up the twitter input box from twitter. shows the link thats it, I hit enter and go to twitter and it will only show the link. I even have a mod custom coded to make sure twitter card is populated. 

Maker of the mod says his code is coming through but it still doesnt work. turned the app off and still doesnt work..

Also went to one of the coders demo site that sells mods in the store here AND the phpfox demo site. Doesnt work on those either.

ALSO, now all the tweets Ive made in the past 5 years have ALL lost the image and meta data in the tweet and only show the link to the pic.

This is a big problem for me.

 

 

 

Last update on June 9, 2021 by eazydoesit.
Be the first person to like this.
Steve

 

 

try this , worked for me 

add txt in root

robots.txt

User-agent: *
allow: /PF.Base/
allow: /PF.Site/
allow: /PF.Src/
Be the first person to like this.

 

 

try this , worked for me 

add txt in root

robots.txt

User-agent: *
allow: /PF.Base/
allow: /PF.Site/
allow: /PF.Src/

 

mine had this User-agent: *
Disallow: /PF.Base/
Disallow: /PF.Site/
Disallow: /PF.Src/,

so i removd and added yours, cleared cache, still didnt work =(

Be the first person to like this.
Steve

check privacy setting for album etc, I am sure you did. 

Be the first person to like this.

check privacy setting for album etc, I am sure you did. 

 

that was one of the first things i tried. 

So yourer on 4.8.5 of v4 and you tweet a users pic and it will poplate the image to twitter?

I mean it doesnt even work on the phpfox demo site....seems like they dont have that feature anymore

Be the first person to like this.

interested in this fix any word on this lately?

Be the first person to like this.

interested in this fix any word on this lately?

 

are you having the same issue? Phpfox needs to look at it, I just have to get back to them. been super busy but will update my ticket this week and report back here

Be the first person to like this.
Vinny

Hi Eazydoesit, 

I can share photo from the demo site to Twitter normally, please check the attachment. If the isssue still persits in your site, kindly submit a ticket in our client area https://clients.phpfox.com/ ; with your site access information, then our engineer will look into your problem soonest.

Regards,

Vinny.

Attachments
Snag_ba5cf52.png 632.04 Kb . 18 Views
Be the first person to like this.