Naresh

I just activated php 8 with th elatest update 4.8.6.

I am able to login on the admin panel and all pages are loading.

But on the home page ( after it loads ) , whenever I click on any link it ends in ERROR 500 .

Any idea what is the issue ?

 

Topics: php 8 issues.
JohnJr

Yes...I spent a day trying to figure out what was wrong.  I thought my backup was messed up as well until I remember after I upgraded I turned on PHP 8.  Either way...php 8 does not work with the new version or the old version :)

Last update on June 28, 2021 by JohnJr.
Be the first person to like this.
Eric

the problem is with me also the new version I can only move in the admin area and all other pages come error 500 but not only with PHP 8 but also with older PHP versions simit I had to re-import my backup the new version does not seem to be correct Function

JohnJr

I did something I probably shouldn't have but I figured they should know ASAP to hopefully fix before others go through the issues I went through.  I added your name to the title for more drama...LOL

 

https://github.com/PHPfox-Official/phpfox-v4-issues/issues/3021

Look I added more text.

Last update on July 13, 2021 by JohnJr.
Naresh

I did something I probably shouldn't have but I figured they should know ASAP to hopefully fix before others go through the issues I went through.  I added your name to the title for more drama...LOL

 

https://github.com/PHPfox-Official/phpfox-v4-issues/issues/3021

 

 

Now that was EPIC .....:smile::smile:

Eric

the error with the error 500 has now been resolved
for me it was a third party app that caused this now it works so far but not with PHP version 8.0.7 but works with 7.4.20

Vinny

Hi All,

This issue occurs because  after upgradation your site to phpFox version 4.8.6, some third party apps don't compatable with php 8.0, so in order to tackle the issue, please help us open ticket via https://clients.phpfox.com/ along with your site access information, our engineer will help you find out which app is causing the problem.

Have a good day and stay safe!

Vinny Ms.

 

Vinny, what you are saying is not necessary true in all cases. Let me explain why I say this.

First of all, I do NOT have any third party apps installed on my site.

A while back, I upgraded my web server from PHP 4.7.8 to PHP 8.0.24. The minute I did that, I began having all kinds of problems, including long stalls, and error 500s all over the place.

I believe that it was Paul who wrote to me and explained that I should pull back to PHP 8.0.22, because 8.0.24 was still too new and was causing some of my issues.

Well, I had the PHP 8.0.20 installer already on my hard drive, so I installed that instead of 8.0.22. I have been using 8.0.20 ever since. In fact, if you are STILL having problems, then you should consider going back to 7.4.8.

So my point is this: I did NOT have any third party apps installed when my problems occurred. The issue was either between phpFox itself and PHP 8.0.24, or between one of phpFox's default apps and PHP 8.0.24.

Last update on July 13, 2021 by Bill Kochman.
Vinny

Hill Bill,

Thanks for your sharing.

May I know whether the issue still remains in your site? If yes, could you please share with me the steps you have done to encouter the problem?

Await for your response.

Regards,

Vinny Ms.

Be the first person to like this.

Vinny, as I explained in my previous post, I have NOT had any 500 errors since I downgraded to PHP 8.0.20.

Also, I do NOT have any third part apps installed, or any third party themes installed.

I run a very clean site now to avoid potential problems.

comment deleted

Last update on July 13, 2021 by Bill Kochman.
Be the first person to like this.
JohnJr

Bill, you should be able to edit that.  If you look at june 28th post by me on this thread a few post above yours, I just wrote...

"Look I added more text."

 

Make sure your clicking on the right three dots...sometime I get confused and click the wrong ones since their are no line between post.

 

Be the first person to like this.

You are correct, John. I guess I was clicking on the wrong three dots. There should be an option to completely delete a comment though.